Author Topic: Build Can't be Complete.  (Read 1310 times)

TrickyDude

  • Guest
Build Can't be Complete.
« on: Fri, Mar 12, 2010 »
Okay, Some of you migth remember that I had Problems with Flixel. But then, I checked FlashDevelop Output and It shows me :

Running process: E:\Programos\Flash Develop\Tools\fdbuild\fdbuild.exe "E:\Domo\Flixel\HelloWorld.as3proj" -ipc bd44072d-d180-4175-8c92-3bef00782d1a -compiler "E:\Programos\Adobe Flex" -notrace -library "E:\Programos\Flash Develop\Library" -cp "E:\Programos\Flixel\AdamAtomic-flixel-565c8d5\org\flixel"
Using the Flex Compiler Shell.
Building HelloWorld
mxmlc -load-config+=obj\HelloWorldConfig.xml -incremental=true -benchmark=false -optimize=true -o obj\HelloWorld634038519728437500
INITIALIZING: Adobe Flex Compiler SHell (fcsh)
Starting new compile.
Loading configuration file E:\Programos\Adobe Flex\frameworks\flex-config.xml
Loading configuration file E:\Domo\Flixel\obj\HelloWorldConfig.xml
E:\Programos\Flixel Library\org\flixel\FlxGame.as: Error: A file found in a source-path must have the same package structure '', as the definition's package, 'org.flixel'.
Build halted with errors (fcsh).

(fcsh)
Done (1)


Seems Like Flixels Fault?
Anyways, I used "Hello World" again.

Liaf

  • Member
  • **
  • Posts: 19
  • Karma: +0/-0
  • yay!
    • View Profile
Re: Build Can't be Complete.
« Reply #1 on: Fri, Mar 12, 2010 »
It surely isn't flixels fault. You probably just extracted flixel to a false directory.
Your directory should look like this.

-Game
  -doc
  -src
  -org (the directory where flixel is stored in)
  -yourMainClass.as
  -all other classes

Then you can just import org.flixel.* in your classes

LestatV3

  • Guest
Re: Build Can't be Complete.
« Reply #2 on: Wed, Mar 31, 2010 »
For me, it worked with the 'org' folder inside src and using:
Code: [Select]
import org.flixel.FlxState
import org.flixel.FlxText
inside PlayState.as, as it extends FlxState and uses FlxText.
Any other method usind ClassPath I tried resulted in an Error.

Paths:
Code: [Select]
HelloWord/
 - bin/
 - src/
 - - org/ (where /flixel/ is)
 - - HelloWord.as
 - - PlayState.as
 - lib/
 - obj/
 - Hello World.as3proj

Good luck :D
Bye

cai

  • Contributor
  • ****
  • Posts: 465
  • Karma: +0/-0
  • the illest of villains
    • View Profile
    • Brandon Cash
Re: Build Can't be Complete.
« Reply #3 on: Wed, Mar 31, 2010 »
You do, indeed, have flixel in the wrong directory.  LestatV3's directory structure is the correct one.

Basically the error message is complaining that you have the package org.flixel in a location other than src/org/flixel.  The package name denotes the directory structure, and must be correct to work.
Follow me on Twitter | Come join us at #flixel on irc.freenode.net!

Paquitox69

  • Guest
Re: Build Can't be Complete.
« Reply #4 on: Mon, Aug 2, 2010 »
[Embed(source="data/nokiafc22.ttf",fontFamily="system",embedAsCFF="false")] protected var junk:String; getting the following 2 mistakes on that lane of code on your flixel FlxGame class...

34 col: 4: Error: transcoding parameter 'embedAsCFF' is not suported by 'flex2.compiler.media.FontTranscoder
34 col 4: Error: Unable to transcode data/noviafc22.tff

if you could help me please... i really want to get started on flixel development... by the error messages im guessing i must of missed a step on the flex2 part but if any of you guys could point it out it would be great