Author Topic: building issues  (Read 1562 times)

bpercevic

  • Member
  • **
  • Posts: 87
  • Karma: +2/-0
    • View Profile
building issues
« on: Sat, Oct 9, 2010 »
something seems to be wrong with flex builder, or my project.  i had a project i was working on over the summer that i havent touched until yesterday.  now, whenever i make a change to the code, save everything, and run the game it plays whatever my project was over the summer, none of my current changes ever go through.  i can't figure out at all what is wrong. 

tried:
-relaunching flex builder
-restarting comp
-reimporting project

any clues?

OmegaStorm

  • Member
  • **
  • Posts: 36
  • Karma: +0/-0
    • View Profile
    • OmegaStorm Productions
Re: building issues
« Reply #1 on: Sat, Oct 9, 2010 »
It's not throwing any errors when compiling?

bpercevic

  • Member
  • **
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Re: building issues
« Reply #2 on: Sat, Oct 9, 2010 »
absolutely nothing.  when i go to the bin-debug folder and play the swf directly or the html wrapped file its still just the old version of the game.  i feel like i must have changed something in the properties of the project but i've gone back and rechecked everything and i cant find it at all.

im using flex builder on mac just in case that information helps

OmegaStorm

  • Member
  • **
  • Posts: 36
  • Karma: +0/-0
    • View Profile
    • OmegaStorm Productions
Re: building issues
« Reply #3 on: Sat, Oct 9, 2010 »
Sounds to me like it's building the swf in a different location, but unfortunately, I don't think I'll be able to help you if it's an issue with Flex Builder itself, as I use FlashDevelop.

bpercevic

  • Member
  • **
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Re: building issues
« Reply #4 on: Sat, Oct 9, 2010 »
thanks anyway,

any way of tracing where the swf is being built in flash develop?
« Last Edit: Sat, Oct 9, 2010 by beaux »

xhunterko

  • Contributor
  • ****
  • Posts: 449
  • Karma: +0/-0
    • View Profile
Re: building issues
« Reply #5 on: Sun, Oct 10, 2010 »
I don't know how you'd do it in flex, but in flash develop, we change our file output like so:

First, click on the project tab.
Then click properties.
Look down to where you see a browse button beside a textbox.
The textbox should read something like "bin\mygame.swf".
This is the location of your swf file, which you can access by hitting browse.

Flashdevelop also has a sidebar that contains your files for viewing and easy access in folders. One of these folders (usually the bin) will contain the swf.

Hope this helped some.
Now on twitter: http://twitter.com/xhunterko I made a game that's in alpha you can buy here: http://xhunterko.itch.io/wave-miner-alpha

NoobsArePeople2

  • Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: building issues
« Reply #6 on: Sun, Oct 10, 2010 »
In Flex Builder, cleaning your project will delete everything in your bin-debug folder and compile the entire project from scratch.

bpercevic

  • Member
  • **
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Re: building issues
« Reply #7 on: Sun, Oct 10, 2010 »
i tried to clean the project but it did not wipe the bin-debug folder, all the files were there untouched.  i also tried changing the launch settings, by default it is set to launch an html wrapper with the swf but i changed it to launch the swf instead but the problem was that the swf it was launching was the one that it wouldnt write over.

but i solved the issue, i downloaded adobe flash builder and just created a new project and transferred my files over and now it builds fine.  flex builder however still doesn't work.

i appreciate your help anyway, thanks!

NoobsArePeople2

  • Member
  • **
  • Posts: 55
  • Karma: +0/-0
    • View Profile
Re: building issues
« Reply #8 on: Mon, Oct 11, 2010 »
Glad you got it working.  If clean wasn't wiping out bin-debug you probably had your project setup with some non-default settings or something like that.  Guess it doesn't matter now :)