Author Topic: Bug Fix!  (Read 1773 times)

camasthecat

  • Contributor
  • ****
  • Posts: 461
  • Karma: +0/-0
  • WOW! 400+ Posts!? Jeez! Do I have a life!?!?
    • View Profile
    • My site for thermalJS, an HTML5/Javascript engine kinda-like flixel:
Bug Fix!
« on: Thu, Dec 22, 2011 »
I think I should post this here...

Well there happens to be a glitch in play() in FlxSprite.
This:
Code: [Select]
if(!Force && (_curAnim != null) && (AnimName == _curAnim.name) && (_curAnim.looped || !finished)) return;

should be this:
Code: [Select]
if(!Force && (_curAnim != null) && (AnimName == _curAnim.name) && (!_curAnim.looped || !finished)) return;
With this fix you can turn off lopping on a animation
This fix should be dropped into the flixel thing on github. :)

axcho

  • Active Member
  • ***
  • Posts: 174
  • Karma: +0/-0
    • View Profile
    • Evolution Live!
Re: Bug Fix!
« Reply #1 on: Fri, Dec 23, 2011 »
Nice catch.

Do you need someone to post it as an issue on GitHub? I'd be happy to do that if you just let me know.

I recently found another bug, with FlxU.formatArray(), and I just posted in on GitHub too:
https://github.com/AdamAtomic/flixel/issues/214

camasthecat

  • Contributor
  • ****
  • Posts: 461
  • Karma: +0/-0
  • WOW! 400+ Posts!? Jeez! Do I have a life!?!?
    • View Profile
    • My site for thermalJS, an HTML5/Javascript engine kinda-like flixel:
Re: Bug Fix!
« Reply #2 on: Fri, Dec 23, 2011 »
Yeah, I have a Github account, but I don't really use it, much less understand how to use it. It would be nice if you post it. Thanks. :)

EDIT: Never mind, I figured it out! :)
https://github.com/AdamAtomic/flixel/issues/216
« Last Edit: Fri, Dec 23, 2011 by camasthecat »

axcho

  • Active Member
  • ***
  • Posts: 174
  • Karma: +0/-0
    • View Profile
    • Evolution Live!
Re: Bug Fix!
« Reply #3 on: Sat, Dec 24, 2011 »
Nice, thanks for figuring it out and posting the issue! :)