Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Daranus

Pages: [1]
1
iOS / [SOLVED] FlxG follow...why doesn't it follow?
« on: Sun, Jul 10, 2011 »
Hey fellas, it's me, once again.


First of all, my Code:
init:
Code: [Select]
    [FlxU setWorldBoundsWithParam1:0 param2:0 param3:100 param4:100];
    focus = [[[FlxObject alloc] initWithX:player.x y:player.y width:1 height:1] autorelease];
    [FlxG followWithParam1:focus param2:15];
    [FlxG followBoundsWithParam1:0 param2:0 param3:stageLength param4:5000 param5:TRUE];
    [FlxG followAdjustWithParam1:0 param2:0];

update:
Code: [Select]
    focus.x =  player.x + 200;
    focus.y =  player.y;
And here is another question:

How can I achieve, that the camera does not only follow in the x direction, but follows equally in the y direction?!...I think not the following itself is the problem, as it follows when the y speed of the player is not that high. But when i do a quick jump, the focus should jump up as well. At the moment, the player jumps out of the screen and comes back in.

How can I do that?

Thanks in advance fellas,
Daranus

Edit: Maybe i got the issue...as i start at position 0,0 it could be that you cannot go into the -y direction?...have to try lowering it from the beginning..

Edit 2: That was it. The camera cannot follow into a -ysomething value. (yes,kinda funny to solve a problem before the post has been approved..l)

2
Normally I wouldnt wanna make a thread for every question, but I guess it's the right way as others can find an answer  more easily when they search like this.

So, here we go again. Like the title suggests, I cannot get particles from a FlxEmitter to collide with the floor.

I tried to set it within the collide: parameter when initializing with the values 0,1,2,10 and nothing really helped me.

After that i tried to get it with the FlxU collideObject function but that didnt help either.

Any suggestions?

Tyvm for any hints again and have a nice weekend,
Daranus

3
Hey folks, I just got into iOS programming with Flixel and now I ran into a strange behavior.

When I use a FlxEmitter, only a black shape of the loaded picture is emitted instead of the picture.

Why is that and how can i change it??!

Tyvm for any hints regardings my problem!

Daranus

P.S.: Beginning with Flixel on iOS is a HUGE pain in the ass because not even the methods and properties mentioned in the Flixel Reference guide are implemented most of the time...so the only thing you can really look at is the code itself....bleh.

Pages: [1]