Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - NateTheGreatt

Pages: 1 ... 3 4 [5]
81
help / Re: Sound not working
« on: Wed, Jun 30, 2010 »
Hi, you can't use .wav embedded for now, only .mp3
Or you can go this way using the flash API.

Ah okay. I wasn't aware of that >.>

Also, that's a very useful link!

Thanks buddy

82
help / Re: Sound not working
« on: Wed, Jun 30, 2010 »
Hi, you can't use .wav embedded for now, only .mp3
Or you can go this way using the flash API.

Ah okay. I wasn't aware of that >.>

Thanks!

83
help / Sound not working
« on: Wed, Jun 30, 2010 »
Code: [Select]
public class PlayState extends FlxState
   {
  [Embed(source='Sounds/boom.wav', mimeType='application/octet-stream')]
  private var soundBoom:Class;
  [Embed(source='Sounds/pewpew.wav', mimeType='application/octet-stream')]
  private var soundLazer:Class;
  [Embed(source='Sounds/splosion.wav', mimeType='application/octet-stream')]
  private var soundSplosion:Class;
//...

This is how I'm instantiating the sounds. All directories are correct and the output is not throwing any errors, yet the sounds are not playing when I call the sound variable ( via FlxG.play(sound) ).

Any suggestions?


Edit: I also just noticed that if I call the sound before all of the other statements in a function or if statement, none of the other statements run, but the state still continues.

Pages: 1 ... 3 4 [5]